im currently trying to get SignalrR 2.0 to work in my ASP.NET MVC 5 application, but something goes horribly wrong. I keep getting this error:

SignalR: No JSON parser found. Please ensure json2.js is referenced before the SignalR.js file if you need to support clients without native JSON parsing support, e.g. IE<8.

Which is weird considering this should be an IE bug, and i'm running my app in Chrome.

Just to make things clear, i'm trying to use SignalR in conjunction with my existing Angular application, which shouldn't be a problem, because i'm just going to make an abstraction on top of SignalR to make it easier to use within my existing app.

Things i've tried:

  1. I've tried switching jQuery version from 2.1.1 to 1.10.2, but that didn't do it.
  2. I've tried referencing the Json2 library. But that didn't work either.

I really need some help here. I can supply various code snippets if necessary :-)

Related posts

Recent Viewed