I'm working through angular's upgrade tutorial to use the UpgradeAdaptor to run my angular 1 app side by side with angular 2. I am running into an issue where importing the @angular packages is clashing with the @ that Razor uses. The first place I found this issue is when importing the UpgradeAdaptor:

import { UpgradeAdapter } from '@angular/upgrade';

I was able to get around that by changing it to '@@anglar/upgrade', but i feel like there has to be a better way. I know I'm going to be using the @ symbol a lot with angular 2 and don't want to have to do @@ each time.

Thanks

Related posts

Recent Viewed