I developed an intranet based application with asp.net mvc 4. I build/published the file using file system publish method then moved the published file to the server (Server 2012) which runs on sql server 2012. As usual, I enabled Windows authentication, enabled directory browsing and created a separate appPool for the application using the integrated pipeline and local system as identity. I then liked the application to it's appPool. On browsing the application, it is viewing as though the css file is missing.

The below is my supposed homepage. enter image description here

Below is my html view referecing the css and js files when viewd from my application:

<!-- core CSS -->
<link href="/Content/css/bootstrap.min.css" rel="stylesheet"/>
<link href="/Content/css/font-awesome.css" rel="stylesheet"/>
<link href="/Content/css/animate.min.css" rel="stylesheet"/>
<link href="/Content/css/prettyPhoto.css" rel="stylesheet"/>
<link href="/Content/css/main.css" rel="stylesheet"/>
<link href="/Content/css/jquery.fancybox-1.3.4.pack.css" rel="stylesheet"/>
<link href="/Content/css/responsive.css" rel="stylesheet"/>

<!-- core JS -->
<script src="/Scripts/modernizr-2.6.2.js"></script>

<script src="/Scripts/jquery-1.10.2.js"></script>
<script src="/Scripts/jquery-migrate-1.2.1.js"></script>
<script src="/Scripts/jquery.unobtrusive-ajax.js"></script>
<script src="/Scripts/main.js"></script>
<script src="/Scripts/jquery.prettyPhoto.js"></script>
<script src="/Scripts/jquery.isotope.min.js"></script>
<script src="/Scripts/html5shiv.js"></script>
<script src="/Scripts/jquery.fancybox-1.3.4.pack.js"></script>
<script src="/Scripts/wow.min.js"></script>
<script src="/Scripts/jquery.validate.js"></script>
<script src="/Scripts/jquery.validate.unobtrusive.js"></script>
<script src="/Scripts/bootstrap.js"></script>
<script src="/Scripts/respond.js"></script>
<script src="//tinymce.cachefly.net/4.2/tinymce.min.js"></script>

And below is the html view of the application after publishing. The CSS file seem not to be referenced. The js files too seem not to be referenced.

<!-- core CSS -->
<link href="/TBC2015Live/Content/css?v=9rtONLVCUCbRdiqwPX0SXmvkuPX-D8w3c-hnpsaUERI1" rel="stylesheet"/>


<!-- core JS -->
<script src="/TBC2015Live/bundles/modernizr?v=wBEWDufH_8Md-Pbioxomt90vm6tJN2Pyy9u9zHtWsPo1"></script>
<script src="/TBC2015Live/bundles/jquery?v=DuNp63axKEm__mWBxQ-SlhlM2syuEL8qBaUB-hzYBAc1"></script>
<script src="/TBC2015Live/bundles/jqueryval?v=NOVQDySGO89wzMzO5x7mWS4C_uAdynpZe_Lk2y-xEM41"></script>
<script src="/TBC2015Live/bundles/bootstrap?v=2Fz3B0iizV2NnnamQFrx-NbYJNTFeBJ2GM05SilbtQU1"></script>

Can anybody help me out?

Related posts

Recent Viewed